symfony1.4でデフォルトのエラーメッセージを変更する。

必須エラーとかが、
「required.」
とかしか出ない時に、いちいちその部分でエラーメッセージを書くのはめんどうなので下記で対応。

config/ProjectConfiguration.class.phpに

public function setup()
{
.....

$this->setValidatorDefaultMessages();
}

public function setValidatorDefaultMessages()
{
sfValidatorBase::setDefaultMessage('invalid', '不正な値です');
sfValidatorBase::setDefaultMessage('required', '必須項目です');
}


を追加すればOK.
スポンサーサイト

トラックバック

コメント

コメントを残す

Secret


プロフィール

U2K

Author:U2K
いろいろプログラムに関しての覚え書きをちょくちょくと書いていきます。

オススメ










オススメ

忍者AdMax

u2k on Twitter

最近の記事