Xcode 8.3 でビルドした時に “The following binaries use incompatible versions of Swift:” のエラーが発生

Xcode 8.3.3 でビルドした時に “The following binaries use incompatible versions of Swift:” のエラーが発生したので、その対処法をメモ。

swift2 から swift3のソースにした関係で、同じプロジェクト上にswift2とswift3が混在してるからダメだったみたい。
下記を試したら治った。


  1. "Product - Clean" で、プロジェクトをクリーン

  2. Xcodeを閉じる

  3. derived dataを削除
    derived dateの場所は Xcode -> Preferences -> Locations にDerived Dataと記載があるので、そこのパスにいく。
    そこに"プロジェクト名 + ランダムな英数字"のディレクトリがあるので、それを丸ごと削除する

  4. Xcodeを再度立ち上げる



参考サイト
Mixing SWIF 2.3 and SWIFT in same project
Xcode 8 beta 4: Build fails with “The following binaries use incompatible versions of Swift:” error
スポンサーサイト

トラックバック

コメント

コメントを残す

Secret


プロフィール

U2K

Author:U2K
いろいろプログラムに関しての覚え書きをちょくちょくと書いていきます。

オススメ










オススメ

忍者AdMax

u2k on Twitter

最近の記事